Setting Ahci Mode On Asus M4a785td-m Evo

Discussion in 'General Hardware' started by XEyedBear, Mar 2, 2019.

  1. XEyedBear

    XEyedBear Geek Trainee

    Likes Received:
    0
    Trophy Points:
    1
    I have an old (but most important) ASUS M4A785TD-M EVO motherboard on which I long since installed an OCZ Vertex 4 SSD. I just checked its performance with the AS SSD benchmarking tool. This showed a 'PCIIDE - BAD' warning. I understand this is because the SSD is not being supported in AHCI mode. When I check in the BIOS, the mode for this SATA connection is set to IDE and it's not immediately obvious how I can set it to AHCI. Let me explain:

    This mobo has 5 SATA 3 ports labelled 1 to 6 in the BIOS (port 4 is not physically on the board). I can set the mode for SATA ports 5 & 6 separately to ports 1 to 4. I have set SATA mode for ports 1 to 4 to RAID because I have a RAID 1 array on ports 2 and 3 (port 1 is an optical drive).

    With ports 1 to 4 set to SATA mode RAID the BIOS allows only the choice of RAID or IDE for the setting of SATA mode for ports 5 and 6. Port 6 is a SATA HDD; port 5 is my OCZ Vertex 4 SSD. RAID did not seem appropriate here so I chose IDE - and hence the warning from the AS benchmarking app.

    The only way I can set ports 5 and 6 to AHCI is to chose the option AHCI in the setting of ports 1 to 4 - but if I do that then I loose my RAID configuration - don't I? Is there some way round this Catch-22, so that I can have a RAID 1 array as well as AHCI for my SSD?
     

Share This Page